JohnCMS 6 vs JohnCMS 7, что выбрать?

2.28K
.
AlkatraZ
╭∩╮ (`-`) ╭∩╮
Как вы знаете, в настоящий момент предлагается 2 версии JohnCMS


JohnCMS 6.x.x
Система находится в режиме долговременной поддержки. Официальных нововведений в данную ветку уже не будет, однако критические исправления безопасности и мелкие багфиксы будут выходить.
---
Достоинства: старая привычная архитектура, много доп. модулей и хаков.
Недостатки: старый код, использует устаревшую библиотеку mysql, не способен работать с PHP 7.


JohnCMS 7.x.x
Новая разработка, код прошел очень большие изменения, самые серьезные за всю историю проекта. Используются современные методы программирования: DI контейнер, Gettext переводчик, PDO и т.д.
Данная версия была задумана как переходной период от JohnCMS к mobiCMS (если последняя увидит свой релиз).
---
Достоинства: современный код, повышенная безопасность и надежность, за счет оптимизации кода хорошая скорость работы. Поддержка коллективного перевода на другие языки с помощью сервиса Crowdin
Недостатки: пока (на данный момент) мало дополнительных модулей, от старых версий они не подходят. Хотя может в последствии кодеры адаптируют свои модули под новую версию.
.
AlkatraZ
╭∩╮ (`-`) ╭∩╮
Что выбрать?
---
В первую очередь проверьте системные требования.
Если на Вашем хостинге нет PHP 5.6 или 7, или MySQL старее, чем 5.5, то дальше можете не читать.
JohnCMS 7 не для Вас, спокойно используйте JohnCMS 6.x.x

Если Вы опытный сайтостроитель, начинаете новый проект и сможете переделать нужные Вам посторонние модули, или же, посторонних модулей вообще не используете, то однозначно ставьте JohnCMS 7

Если у Вас уже давно работающий сайт, на который установлено много сторонних модулей, то оставайтесь на той версии, на которой работаете. JohnCMS 7 Вам не нужен.

Если у Вас рабочий сайт, но нет дополнительных модулей, или хаков, то имеет смысл рассмотреть переход на новую версию. Выбор за Вами.
.
для меня johnCmS6 НОРМ
.
# AlkatraZ (22.01.2017 / 19:19)
Хотя может в последствии кодеры адаптируют свои модули под новую версию.
прежде чем адптировать надо выучить пдо. Тут таких по пальцам пересчитать можно, и учитывая это, можно смело сказать что написание будущих модулей почти равняется нулю ибо у них свои дела есть.
Они могут писать за деньги, но откуда тут одмины с деньгами..
Придется тебе самому писать все модули в последствии..
.
# AlkatraZ (22.01.2017 / 19:19)
Как вы знаете, в настоящий момент предлагается 2 версии JohnCMS


JohnCMS 6.x.x
Система находится в режиме долговременной поддержки. Официальных нововведений в данную ветку уже не будет, однако кр
скока раз просили внедрить редактор одекватный то в шестерку..
.
Ей 25
# Fublin (23.01.2017 / 06:38)
прежде чем адптировать надо выучить пдо. Тут таких по пальцам пересчитать можно, и учитывая это, можно смело сказать что написание будущих модулей почти равняется нулю ибо у них свои дела есть.
Они м
Что там учить? Запросы кругом одинаковые. В не зависимости ПДО это или Мускул. Драйвер базы данных также на вид запросов не влияет.
А как ты эти запросы в БД отправлять тебя волновать не должно. Так $db->query -или так mysql_query.
.
Its so complicated but interested!
.
# ValekS (23.01.2017 / 18:35)
Что там учить? Запросы кругом одинаковые. В не зависимости ПДО это или Мускул. Драйвер базы данных также на вид запросов не влияет.
А как ты эти запросы в БД отправлять тебя волновать не должно. Так
Ну тогда пиши модули для семерки, я потом список выложу чо надо
.
AlkatraZ, Олег, встрой вайсиб какой нибудь в шестерку что бы фоты грузить пачкками к одному ид, и занимайся дальше чем там занимаешся.. Ну серьезно же.. Не все поймут то что ты сейчас делаешь ибо не все попутно изучают пых в вузах, школах, институтах..
Шестерка для них наиболее оптимальный вариант для этого, тока много там нет все равно, полноценный движок не сделать по любому потому и народа мало стало...

Ах..да, как теперь встроить то редактор когда ты уже версию запихал сюда седьмую... То есть теперь мне придется кодера искать хорошего.. Который именно разбирается в том что ты писал про уязвимости редакторов... И чо нам делать теперь голодранцам, ждать еще семь лет моби а потом понять что он нам тяжел в восприятии и мы зря ждали ?
Ты для кого пишишь сейчас всё это, для Рамзеза или Доктора ?..Дык они и сами мыслю себе напишут что надо...
Для меня и таких же как я ?.. Я не пойму..

Для себя ?.. Ну а кто будет поддерживать версию шестую как ты сам озвучил если ты сейчас всецело занят апгрейдом семерки под моби и когда это закончится никто воще понятия не имеет..

Встрой ридактор в шестерку говорю.. Прошу уже три года !
.
человек И пароход
что за ридактор может я допишу
Всего: 133